use strict;
my $str = '<html><head><title></title></head><body>my content</body></html>';
my $regex = qr/.*?(<body>.*?<\/body>).*/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";