#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iUs)<([A-Za-z]{1,7}) .*class='([a-zA-Z0-9_ ]{0,})searchedclass[ '].*>.*<\/\1.*>"
Local $sString = "<div>" & @CRLF & _
"<table>" & @CRLF & _
"<tr>" & @CRLF & _
"<td style='abc' class='searchedclass noprint' style='color:#ff0000'>some random text" & @CRLF & _
"</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")