const regex = /<([A-Za-z]{1,7}) .*class='([a-zA-Z0-9_ ]{0,})searchedclass[ '].*>.*<\/\1.*>/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([A-Za-z]{1,7}) .*class=\'([a-zA-Z0-9_ ]{0,})searchedclass[ \'].*>.*<\\\/\\1.*>', 'is')
const str = `<div>
<table>
<tr>
<td style='abc' class='searchedclass noprint' style='color:#ff0000'>some random text
</td>
</tr>
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}