$re = '/<([A-Za-z]{1,7}) .*class=\'([a-zA-Z0-9_ ]{0,})searchedclass[ \'].*>.*<\/\1.*>/iUs';
$str = '<div>
<table>
<tr>
<td style=\'abc\' class=\'searchedclass noprint\' style=\'color:#ff0000\'>some random text
</td>
</tr>
</table>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);