use strict;
my $str = '<div>
<table>
<tr>
<td style=\'abc\' class=\'searchedclass noprint\' style=\'color:#ff0000\'>some random text
</td>
</tr>
</table>';
my $regex = qr/<([A-Za-z]{1,7}) .*class='([a-zA-Z0-9_ ]{0,})searchedclass[ '].*>.*<\/\1.*>/isp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}