#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?=[A-Z]{5}\b)(?:\1|(?!\2)([B-Z])()|(?!\3)A())+\b\2"
Local $sString = "BBABB -> true" & @CRLF & _
"ABBBB -> true" & @CRLF & _
"BABBB -> true" & @CRLF & _
"CCACC -> true" & @CRLF & _
"CCCCA -> true" & @CRLF & _
"AAAAA -> false (change "[B-Z]" to "[A-Z]" to match this)" & @CRLF & _
"CCBAB -> false" & @CRLF & _
"CCCAA -> false" & @CRLF & _
"ABCCB -> false" & @CRLF & _
"BACBB -> false"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")