re = /\b(?=[A-Z]{5}\b)(?:\1|(?!\2)([B-Z])()|(?!\3)A())+\b\2/m
str = 'BBABB -> true
ABBBB -> true
BABBB -> true
CCACC -> true
CCCCA -> true
AAAAA -> false (change "[B-Z]" to "[A-Z]" to match this)
CCBAB -> false
CCCAA -> false
ABCCB -> false
BACBB -> false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end