using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=[A-Z]{5}\b)(?:\1|(?!\2)([B-Z])()|(?!\3)A())+\b\2";
string input = @"BBABB -> true
ABBBB -> true
BABBB -> true
CCACC -> true
CCCCA -> true
AAAAA -> false (change ""[B-Z]"" to ""[A-Z]"" to match this)
CCBAB -> false
CCCAA -> false
ABCCB -> false
BACBB -> false";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}