$re = '/\b(?=[A-Z]{5}\b)(?:\1|(?!\2)([B-Z])()|(?!\3)A())+\b\2/m';
$str = 'BBABB -> true
ABBBB -> true
BABBB -> true
CCACC -> true
CCCCA -> true
AAAAA -> false (change "[B-Z]" to "[A-Z]" to match this)
CCBAB -> false
CCCAA -> false
ABCCB -> false
BACBB -> false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);