const regex = /\b(?=[A-Z]{5}\b)(?:\1|(?!\2)([B-Z])()|(?!\3)A())+\b\2/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?=[A-Z]{5}\\b)(?:\\1|(?!\\2)([B-Z])()|(?!\\3)A())+\\b\\2', 'gm')
const str = `BBABB -> true
ABBBB -> true
BABBB -> true
CCACC -> true
CCCCA -> true
AAAAA -> false (change "[B-Z]" to "[A-Z]" to match this)
CCBAB -> false
CCCAA -> false
ABCCB -> false
BACBB -> false`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}