#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?U)(?!<span class=\"myclass\"\>.*)(\{\{.*?\}\})(?!.*<\/span>)"
Local $sString = "<span class="myclass">{{$$x = {-b \pm \sqrt{b^2-4ac} \over 2a}.$$}}</span>" & @CRLF & _
"" & @CRLF & _
"<p>{{$$x = {-b \pm \sqrt{b^2-4ac} \over 2a}.$$}}</p>" & @CRLF & _
"" & @CRLF & _
"<p>{{any text}}</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")