using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!<span class=\""myclass\""\>.*)(\{\{.*?\}\})(?!.*<\/span>)";
string input = @"<span class=""myclass"">{{$$x = {-b \pm \sqrt{b^2-4ac} \over 2a}.$$}}</span>
<p>{{$$x = {-b \pm \sqrt{b^2-4ac} \over 2a}.$$}}</p>
<p>{{any text}}</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}