$re = '/(?!<span class=\"myclass\"\>.*)(\{\{.*?\}\})(?!.*<\/span>)/U';
$str = '<span class="myclass">{{$$x = {-b \\pm \\sqrt{b^2-4ac} \\over 2a}.$$}}</span>
<p>{{$$x = {-b \\pm \\sqrt{b^2-4ac} \\over 2a}.$$}}</p>
<p>{{any text}}</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);