re = /(?!<span class=\"myclass\"\>.*)(\{\{.*?\}\})(?!.*<\/span>)/
str = '<span class="myclass">{{$$x = {-b \\pm \\sqrt{b^2-4ac} \\over 2a}.$$}}</span>
<p>{{$$x = {-b \\pm \\sqrt{b^2-4ac} \\over 2a}.$$}}</p>
<p>{{any text}}</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end