import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!<span class=\\\"myclass\\\"\\>.*)(\\{\\{.*?\\}\\})(?!.*<\\/span>)";
final String string = "<span class=\"myclass\">{{$$x = {-b \\pm \\sqrt{b^2-4ac} \\over 2a}.$$}}</span>\n\n"
+ "<p>{{$$x = {-b \\pm \\sqrt{b^2-4ac} \\over 2a}.$$}}</p>\n\n"
+ "<p>{{any text}}</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}