using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9A-Za-z]*[!@#$%^&*()_+\-=\[\]{};':""\\|,.<>\/?][0-9a-zA-Z]*$";
string input = @"@
@a
a@
aa
aa@@
THisisSome#randomPassword";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}