package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[0-9A-Za-z]*[!@#$%^&*()_+\-=\[\]{};':"\\|,.<>\/?][0-9a-zA-Z]*$`)
var str = `@
@a
a@
aa
aa@@
THisisSome#randomPassword`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}