const regex = /^[0-9A-Za-z]*[!@#$%^&*()_+\-=\[\]{};':"\\|,.<>\/?][0-9a-zA-Z]*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9A-Za-z]*[!@#$%^&*()_+\\-=\\[\\]{};\':"\\\\|,.<>\\\/?][0-9a-zA-Z]*$', 'gmi')
const str = `@
@a
a@
aa
aa@@
THisisSome#randomPassword`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}