re = /^[0-9A-Za-z]*[!@#$%^&*()_+\-=\[\]{};':"\\|,.<>\/?][0-9a-zA-Z]*$/mi
str = '@
@a
a@
aa
aa@@
THisisSome#randomPassword'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end