#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)["']([\a-zA-Z0-9-_]*?logo[a-zA-Z0-9\-_]*?\.(?:png|jpg|jpeg)).*?['"]"
Local $sString = "/example/logo.png" & @CRLF & _
"/example/logo_adsadsa.jpg" & @CRLF & _
""/e/logo_adsada.jpg?size=400"" & @CRLF & _
"src="dadsadsadadadadsadasdadsadsalogosdsd.png"" & @CRLF & _
"" & @CRLF & _
"<html>" & @CRLF & _
" <head>" & @CRLF & _
" <style>" & @CRLF & _
" someclass {" & @CRLF & _
" background-image: url("/css/images/logo2.jpg");"" & @CRLF & _
" background-color: #cccccc;" & @CRLF & _
" }" & @CRLF & _
" </style>" & @CRLF & _
" </head>" & @CRLF & _
" " & @CRLF & _
" <body>" & @CRLF & _
" <h1>Hello World!</h1>" & @CRLF & _
" </body>" & @CRLF & _
"<html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")