# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\"']([\a-zA-Z0-9-_]*?logo[a-zA-Z0-9\-_]*?\.(?:png|jpg|jpeg)).*?['\"]"
test_str = ("/example/logo.png\n"
"/example/logo_adsadsa.jpg\n"
"\"/e/logo_adsada.jpg?size=400\"\n"
"src=\"dadsadsadadadadsadasdadsadsalogosdsd.png\"\n\n"
"<html>\n"
" <head>\n"
" <style>\n"
" someclass {\n"
" background-image: url(\"/css/images/logo2.jpg\");\"\n"
" background-color: #cccccc;\n"
" }\n"
" </style>\n"
" </head>\n"
" \n"
" <body>\n"
" <h1>Hello World!</h1>\n"
" </body>\n"
"<html>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.