using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[""']([\a-zA-Z0-9-_]*?logo[a-zA-Z0-9\-_]*?\.(?:png|jpg|jpeg)).*?['""]";
string input = @"/example/logo.png
/example/logo_adsadsa.jpg
""/e/logo_adsada.jpg?size=400""
src=""dadsadsadadadadsadasdadsadsalogosdsd.png""
<html>
<head>
<style>
someclass {
background-image: url(""/css/images/logo2.jpg"");""
background-color: #cccccc;
}
</style>
</head>
<body>
<h1>Hello World!</h1>
</body>
<html>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}