// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)["']([\a-zA-Z0-9-_]*?logo[a-zA-Z0-9\-_]*?\.(?:png|jpg|jpeg)).*?['"]"#).unwrap();
let string = "/example/logo.png
/example/logo_adsadsa.jpg
\"/e/logo_adsada.jpg?size=400\"
src=\"dadsadsadadadadsadasdadsadsalogosdsd.png\"
<html>
<head>
<style>
someclass {
background-image: url(\"/css/images/logo2.jpg\");\"
background-color: #cccccc;
}
</style>
</head>
<body>
<h1>Hello World!</h1>
</body>
<html>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}