re = /["']([\a-zA-Z0-9-_]*?logo[a-zA-Z0-9\-_]*?\.(?:png|jpg|jpeg)).*?['"]/mi
str = '/example/logo.png
/example/logo_adsadsa.jpg
"/e/logo_adsada.jpg?size=400"
src="dadsadsadadadadsadasdadsadsalogosdsd.png"
<html>
<head>
<style>
someclass {
background-image: url("/css/images/logo2.jpg");"
background-color: #cccccc;
}
</style>
</head>
<body>
<h1>Hello World!</h1>
</body>
<html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end