#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!<scr>).)*<scr>(?!.*<scr>).*$"
Local $sString = "hello-<scr>Keephello-endofstring" & @CRLF & _
"hello-<scr><scr>Keephello-endofstring" & @CRLF & _
"" & @CRLF & _
"//NOT OK" & @CRLF & _
"test-<scr>bla<scr>bla-end" & @CRLF & _
"hello-Keephello-end "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")