import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!<scr>).)*<scr>(?!.*<scr>).*$";
final String string = "hello-<scr>Keephello-endofstring\n"
+ "hello-<scr><scr>Keephello-endofstring\n\n"
+ "//NOT OK\n"
+ "test-<scr>bla<scr>bla-end\n"
+ "hello-Keephello-end ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}