$re = '/^(?:(?!<scr>).)*<scr>(?!.*<scr>).*$/m';
$str = 'hello-<scr>Keephello-endofstring
hello-<scr><scr>Keephello-endofstring
//NOT OK
test-<scr>bla<scr>bla-end
hello-Keephello-end ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);