const regex = /^(?:(?!<scr>).)*<scr>(?!.*<scr>).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!<scr>).)*<scr>(?!.*<scr>).*$', 'gm')
const str = `hello-<scr>Keephello-endofstring
hello-<scr><scr>Keephello-endofstring
//NOT OK
test-<scr>bla<scr>bla-end
hello-Keephello-end `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}