import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{[^\\{\\}]*\\}\\s*(\\d+)\\s+\\{[^\\{\\}]*\\}\\s*\\d+\\s+\\{[^\\{\\}]*\\}\\s*(\\d+)";
final String string = "{ abc1 } 1\n"
+ "{ cde1 } 101\n"
+ "{ fgh1 } 1\n"
+ "{ ijk1 } 2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}