import re
regex = re.compile(r"^{[^{}]*}\s*(\d+)\s+{[^{}]*}\s*\d+\s+{[^{}]*}\s*(\d+)")
test_str = ("{ abc1 } 1\n"
"{ cde1 } 101\n"
"{ fgh1 } 1\n"
"{ ijk1 } 2")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")