const regex = /^{[^{}]*}\s*(\d+)\s+{[^{}]*}\s*\d+\s+{[^{}]*}\s*(\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^{[^{}]*}\\s*(\\d+)\\s+{[^{}]*}\\s*\\d+\\s+{[^{}]*}\\s*(\\d+)', '')
const str = `{ abc1 } 1
{ cde1 } 101
{ fgh1 } 1
{ ijk1 } 2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}