re = /^{[^{}]*}\s*(\d+)\s+{[^{}]*}\s*\d+\s+{[^{}]*}\s*(\d+)/
str = '{ abc1 } 1
{ cde1 } 101
{ fgh1 } 1
{ ijk1 } 2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end