$re = '/^{[^{}]*}\s*(\d+)\s+{[^{}]*}\s*\d+\s+{[^{}]*}\s*(\d+)/';
$str = '{ abc1 } 1
{ cde1 } 101
{ fgh1 } 1
{ ijk1 } 2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);