#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\W{3}(\s|\s\s)(\«|\")\W{1,}\d+\W+\d+"
Local $sString = "ООО ноксиВ“" & @CRLF & _
"Банк получателя" & @CRLF & _
"кпп 775701001" & @CRLF & _
"е ит” г „ Москва" & @CRLF & _
"сч, 40702810100120000345" & @CRLF & _
"БИК 041501712" & @CRLF & _
"СЧ, 3010181 700000000712" & @CRLF & _
"Филиал А КБ “Ст ой" & @CRLF & _
"Плательщик:" & @CRLF & _
"1 Оказание б" & @CRLF & _
"СЧЕТ N? 21 от 21 Ноября 2017 г." & @CRLF & _
"ООО «Береза“, инн 7754003578, кпп 775701001, 117000, г.москва," & @CRLF & _
"Наименование" & @CRLF & _
"товара" & @CRLF & _
"галте ких" & @CRLF & _
"Всего наименований 1, на сумму 1' 180,00" & @CRLF & _
"ниц" & @CRLF & _
"а" & @CRLF & _
"изме-" & @CRLF & _
"ения" & @CRLF & _
"шт" & @CRLF & _
"Коли-" & @CRLF & _
"чество" & @CRLF & _
"Цена" & @CRLF & _
"1 ooo„oo" & @CRLF & _
"Итого:" & @CRLF & _
"н С18" & @CRLF & _
"Всего к оплате:" & @CRLF & _
"Сумма" & @CRLF & _
"1000,00" & @CRLF & _
"1000.00" & @CRLF & _
"180.00" & @CRLF & _
"1180.00" & @CRLF & _
"Одна тысяча сто восемьдесят рублей 00 копеек" & @CRLF & _
"Руководитель предприятия" & @CRLF & _
"Главный бухгалтер" & @CRLF & _
"(Аникоз Б.Е.)" & @CRLF & _
"(Аников"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")