import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\W{3}(\\s|\\s\\s)(\\«|\\\")\\W{1,}\\d+\\W+\\d+";
final String string = "ООО ноксиВ“\n"
+ "Банк получателя\n"
+ "кпп 775701001\n"
+ "е ит” г „ Москва\n"
+ "сч, 40702810100120000345\n"
+ "БИК 041501712\n"
+ "СЧ, 3010181 700000000712\n"
+ "Филиал А КБ “Ст ой\n"
+ "Плательщик:\n"
+ "1 Оказание б\n"
+ "СЧЕТ N? 21 от 21 Ноября 2017 г.\n"
+ "ООО «Береза“, инн 7754003578, кпп 775701001, 117000, г.москва,\n"
+ "Наименование\n"
+ "товара\n"
+ "галте ких\n"
+ "Всего наименований 1, на сумму 1' 180,00\n"
+ "ниц\n"
+ "а\n"
+ "изме-\n"
+ "ения\n"
+ "шт\n"
+ "Коли-\n"
+ "чество\n"
+ "Цена\n"
+ "1 ooo„oo\n"
+ "Итого:\n"
+ "н С18\n"
+ "Всего к оплате:\n"
+ "Сумма\n"
+ "1000,00\n"
+ "1000.00\n"
+ "180.00\n"
+ "1180.00\n"
+ "Одна тысяча сто восемьдесят рублей 00 копеек\n"
+ "Руководитель предприятия\n"
+ "Главный бухгалтер\n"
+ "(Аникоз Б.Е.)\n"
+ "(Аников";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}