# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\W{3}(\s|\s\s)(\«|\")\W{1,}\d+\W+\d+"
test_str = ("ООО ноксиВ“\n"
"Банк получателя\n"
"кпп 775701001\n"
"е ит” г „ Москва\n"
"сч, 40702810100120000345\n"
"БИК 041501712\n"
"СЧ, 3010181 700000000712\n"
"Филиал А КБ “Ст ой\n"
"Плательщик:\n"
"1 Оказание б\n"
"СЧЕТ N? 21 от 21 Ноября 2017 г.\n"
"ООО «Береза“, инн 7754003578, кпп 775701001, 117000, г.москва,\n"
"Наименование\n"
"товара\n"
"галте ких\n"
"Всего наименований 1, на сумму 1' 180,00\n"
"ниц\n"
"а\n"
"изме-\n"
"ения\n"
"шт\n"
"Коли-\n"
"чество\n"
"Цена\n"
"1 ooo„oo\n"
"Итого:\n"
"н С18\n"
"Всего к оплате:\n"
"Сумма\n"
"1000,00\n"
"1000.00\n"
"180.00\n"
"1180.00\n"
"Одна тысяча сто восемьдесят рублей 00 копеек\n"
"Руководитель предприятия\n"
"Главный бухгалтер\n"
"(Аникоз Б.Е.)\n"
"(Аников")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.