use strict;
my $str = 'ООО ноксиВ“
Банк получателя
кпп 775701001
е ит” г „ Москва
сч, 40702810100120000345
БИК 041501712
СЧ, 3010181 700000000712
Филиал А КБ “Ст ой
Плательщик:
1 Оказание б
СЧЕТ N? 21 от 21 Ноября 2017 г.
ООО «Береза“, инн 7754003578, кпп 775701001, 117000, г.москва,
Наименование
товара
галте ких
Всего наименований 1, на сумму 1\' 180,00
ниц
а
изме-
ения
шт
Коли-
чество
Цена
1 ooo„oo
Итого:
н С18
Всего к оплате:
Сумма
1000,00
1000.00
180.00
1180.00
Одна тысяча сто восемьдесят рублей 00 копеек
Руководитель предприятия
Главный бухгалтер
(Аникоз Б.Е.)
(Аников';
my $regex = qr/^\W{3}(\s|\s\s)(\«|\")\W{1,}\d+\W+\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}