package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\W{3}(\s|\s\s)(\«|\")\W{1,}\d+\W+\d+`)
var str = `ООО ноксиВ“
Банк получателя
кпп 775701001
е ит” г „ Москва
сч, 40702810100120000345
БИК 041501712
СЧ, 3010181 700000000712
Филиал А КБ “Ст ой
Плательщик:
1 Оказание б
СЧЕТ N? 21 от 21 Ноября 2017 г.
ООО «Береза“, инн 7754003578, кпп 775701001, 117000, г.москва,
Наименование
товара
галте ких
Всего наименований 1, на сумму 1' 180,00
ниц
а
изме-
ения
шт
Коли-
чество
Цена
1 ooo„oo
Итого:
н С18
Всего к оплате:
Сумма
1000,00
1000.00
180.00
1180.00
Одна тысяча сто восемьдесят рублей 00 копеек
Руководитель предприятия
Главный бухгалтер
(Аникоз Б.Е.)
(Аников`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}