using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/@[^/@]*(*SKIP)(*F)|[^/]+";
string substitution = @"a:$0";
string input = @"path/to/folder/@here";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}