re = /\/@[^\/@]*(*SKIP)(*F)|[^\/]+/m
str = 'path/to/folder/@here'
subst = 'a:$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result