import re
regex = re.compile(r"/@[^/@]*(*SKIP)(*F)|[^/]+", flags=re.MULTILINE)
test_str = "path/to/folder/@here"
subst = "a:$0"
result = regex.sub(subst, test_str)
if result:
print(result)