#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Specs:(?:(?!^Specs:)[\s\S])*UnknownError:\s*(.*)"
Local $sString = "Specs: /var/lib/jenkins-slave/workspace//tests/js/e2e/ui_e2e/tests/test_one.js" & @CRLF & _
"Selenium URL: http://10.20.40.54:4444/wd/hub" & @CRLF & _
"" & @CRLF & _
"..... number of different strings here...." & @CRLF & _
"" & @CRLF & _
"Executed 25 of 25 specs SUCCESS in 1 min 23 secs." & @CRLF & _
"-----" & @CRLF & _
"Specs: /var/lib/jenkins-slave/workspace//tests/js/e2e/ui_e2e/tests/test_two.js" & @CRLF & _
"" & @CRLF & _
"..... number of different strings here...." & @CRLF & _
"" & @CRLF & _
"UnknownError: Due to a previous error, this job has already finished. You can learn more at"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")