$re = '/^Specs:(?:(?!^Specs:)[\s\S])*UnknownError:\s*(.*)/m';
$str = 'Specs: /var/lib/jenkins-slave/workspace//tests/js/e2e/ui_e2e/tests/test_one.js
Selenium URL: http://10.20.40.54:4444/wd/hub
..... number of different strings here....
Executed 25 of 25 specs SUCCESS in 1 min 23 secs.
-----
Specs: /var/lib/jenkins-slave/workspace//tests/js/e2e/ui_e2e/tests/test_two.js
..... number of different strings here....
UnknownError: Due to a previous error, this job has already finished. You can learn more at';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);