import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Specs:(?:(?!^Specs:)[\\s\\S])*UnknownError:\\s*(.*)";
final String string = "Specs: /var/lib/jenkins-slave/workspace//tests/js/e2e/ui_e2e/tests/test_one.js\n"
+ "Selenium URL: http://10.20.40.54:4444/wd/hub\n\n"
+ "..... number of different strings here....\n\n"
+ "Executed 25 of 25 specs SUCCESS in 1 min 23 secs.\n"
+ "-----\n"
+ "Specs: /var/lib/jenkins-slave/workspace//tests/js/e2e/ui_e2e/tests/test_two.js\n\n"
+ "..... number of different strings here....\n\n"
+ "UnknownError: Due to a previous error, this job has already finished. You can learn more at";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}