# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^Specs:(?:(?!^Specs:)[\s\S])*UnknownError:\s*(.*)"
test_str = ("Specs: /var/lib/jenkins-slave/workspace//tests/js/e2e/ui_e2e/tests/test_one.js\n"
"Selenium URL: http://10.20.40.54:4444/wd/hub\n\n"
"..... number of different strings here....\n\n"
"Executed 25 of 25 specs SUCCESS in 1 min 23 secs.\n"
"-----\n"
"Specs: /var/lib/jenkins-slave/workspace//tests/js/e2e/ui_e2e/tests/test_two.js\n\n"
"..... number of different strings here....\n\n"
"UnknownError: Due to a previous error, this job has already finished. You can learn more at")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.