#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\d+\.)[^\S\r\n]+(\d+\.)"
Local $sString = "It costs 2. 5. That is a lot." & @CRLF & _
"It costs 2. 5 items, that is a lot."
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)