using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+\.)[^\S\r\n]+(\d+\.)";
string substitution = @"\1\2";
string input = @"It costs 2. 5. That is a lot.
It costs 2. 5 items, that is a lot.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}