re = /\b(\d+\.)[^\S\r\n]+(\d+\.)/m
str = 'It costs 2. 5. That is a lot.
It costs 2. 5 items, that is a lot.'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result