$re = '/\b(\d+\.)[^\S\r\n]+(\d+\.)/m';
$str = 'It costs 2. 5. That is a lot.
It costs 2. 5 items, that is a lot.';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;