import re
regex = re.compile(r"\b(\d+\.)[^\S\r\n]+(\d+\.)", flags=re.MULTILINE)
test_str = ("It costs 2. 5. That is a lot.\n"
"It costs 2. 5 items, that is a lot.")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)